Data congestion

Incident Report for Insightful

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 20:40 UTC

Identified

We have detected some data congestion, which might cause delays in processing or loading certain info. Our team is working to get things flowing smoothly again. Thanks for bearing with us - we'll keep you posted.
Posted Mar 27, 2026 - 16:37 UTC
This incident affected: Frontend (Frontend Application, Frontend API).