Congestion during screenshots processing
Incident Report for Insightful
Resolved
This incident has been resolved.
Posted Jun 28, 2021 - 21:21 UTC
Identified
We have identified the issue and are working on the solution.
Posted Jun 28, 2021 - 14:35 UTC
This incident affected: Data collection and processing (Screenshots).