Data congestion

Incident Report for Insightful

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 13:37 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 24, 2026 - 12:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 12:12 UTC

Identified

We have detected some data congestion, which might cause delays in processing or loading certain info. Our team is working to get things flowing smoothly again. Thanks for bearing with us - we'll keep you posted.
Posted Feb 24, 2026 - 11:47 UTC
This incident affected: Frontend (Frontend Application, Frontend API) and Data collection and processing (Gateway, Apps and websites usage, Screenshots, Shifts, Breaks, Time on projects and tasks, Productivity, BIM, RPA, Agent, ATM, Locations, Audit, Manual Entry, Screen recording).