Completed
The scheduled maintenance has been completed.
Posted Jun 01, 2025 - 09:48 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2025 - 08:00 UTC
Scheduled
We've got maintenance planned for 2025-06-01, and access to the Insightful dashboard might be limited during that window. However, the employee data should be collected without interruptions and synced to your dashboard after downtime.
Thank you for your patience!
Posted May 30, 2025 - 13:25 UTC
This scheduled maintenance affected: Backend microservices (IAM, Emails, Analytics, Realtime, Apps and sites directory, Project management, Billing, Email reports, Jobs, Installation generator, Files, Session recording, Directory, Notifications, Utils), Frontend (Frontend Application, Frontend API), Data collection and processing (Gateway, Apps and websites usage, Screenshots, Shifts, Breaks, Time on projects and tasks, Productivity, BIM, RPA, Agent, ATM, Locations, Audit, Manual Entry), Integrations (Trello, Jira, Monday, Data warehouse, Merge, Calendar Integration, Platform Integrations, AI Services), and Website, Google Cloud Platform Google Kubernetes Engine, Google Cloud Platform Google Cloud Storage, Elastic Cloud Elasticsearch connectivity: GCP us-east4, SendGrid API v3, Stripe API, Stripe Webhooks, Stripe Emails, Stripe JS, Intercom Medium message delivery, Intercom Small message delivery, Intercom Web Messenger, Intercom Intercom Webhooks.