The Workpuls platform is down
Incident Report for Insightful
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 13:37 UTC
Investigating
Currently, our platform is down due to some technical issues. We are aware of the issue and working to resolve as soon as possible.
Posted Jan 13, 2022 - 12:53 UTC