Data Processing Delay
Incident Report for Insightful
Resolved
This incident has been resolved.
Posted May 23, 2023 - 00:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2023 - 00:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 22, 2023 - 22:52 UTC
Investigating
We are currently experiencing a delay in the data processing for today, May 22. Our team is actively investigating and working on this. Your patience and understanding are highly appreciated.
Posted May 22, 2023 - 20:21 UTC
This incident affected: Data collection and processing (Apps and websites usage, Productivity).